Answered
0
1

Hey there,

We are using async multisound containers for our adaptive music system, as recommended to use here: http://www.fmod.org/questions/question/playing-multisound-to-the-end-in-loop/

After integrating the music from our musician the system was completely broken and files playing multiple times and getting out of sync, destroying the whole experience. I did some testing and found out that the problem was within large files that where not able to be streamed in realtime. I isolated the problem in a simple project with just one audio file that works with nonstreamed settings, but breaks with streamed settings:
Screenshots: https://imgur.com/a/R9tRw
Project: https://drive.google.com/file/d/1C8Q-l5mBYUddtlO91rrhfHL6iuN-jjPj/view?usp=sharing

Using synced containers works as well. We are however using async containers in order to play tails of snippets into the next snippet (Linked at the top).
Now I’m wondering: Is this intended,because the containers are async? Can you do anything against it? Does it work in newer versions (We’re still at 1.09.04)?

Cheers
JOhannes

  • You must to post comments
Best Answer
0
0

Hi Johannes,

There was a streaming issue that caused instruments to go out of sync and was fixed in 1.09.07. Could you please download the latest version of FMOD Studio 1.09 and see if the issue persists there?

Thanks,
Richard

  • Johannes Deml

    Hi Richard,

    I downloaded version 1.09.10 to test your suggestion, sadly the problem still persists: https://imgur.com/a/H0ZZY

  • Richard Simms

    Hi Johannes,

    I’ve taken a closer look into this and the issue seems to come from the LargeFile.wav itself. I’ve raised an investigation bug into what is happening here, but I found the issue is sort of fixed if you save it out as 16 bit PCM at 44.1Khz, and don’t touch the Pitch property. We will investigate why this issue is arising in the meantime.

    Thanks for bringing this to our attention.

    Thanks,
    Richard

  • Richard Simms

    Hi Johannes,

    To give you an update – the file provided is using up all the streaming bandwidth due to the high quality nature of the file. If you reduce it down to the above settings (44.1kHz and 16 bit PCM) it should help with the situation.

    Thanks,
    Richard

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.