Answered
0
0

Hello,
I’m evaluating two good spatialization plugins for FMOD using Unity Integration: Oculus Spatialize and Two Big Ears’ 3Dception.

I’ve a common problem with both regarding 3D placement (x,y,z) of the sound sources.

It looks like every sound source I put in the Unity scene is placed at [0,0,0]

THIS IS WHAT I DID – Unity5 on OSX 10.11
(two different test with Oculus and 3Dception )
– successfully installed the 3rd party spatialization plugin runtime over FMOD Unity integration 2.0 following the specific documentation
– create a 3D sound event within FMOD Editor (v1.08) by replacing the standard FMOD 3D Panner with the 3rd party plugin
– Inside Unity I added an FMOD Studio Event Emitter on a Gameobject that plays on Level Start

THIS IS WHAT I GET
(same behaviour with both plugins)
– the sound source is placed at 0,0,0 (these spatialization plugins are very effective, so listening thru headphones you can tell exactly where the sound is coming from)
– The Fmod event emitter script summarize the sound property as “2D Sound”, maybe because there’s no standard 3D panner on it. I suspect this is the reason why the sound location has not been updated. In addition, no propagation zone (min/max distance) is displayed inside editor.

Since this buggy behaviour is the same for both plugins I suppose the problem is from FMOD Unity Integration side
Maybe some “Force 3D” flag for 3rd party 3D panner has to be added?
Or am I doing something wrong?

Please let me know
Thanks!

Gianni Ricciardi
Audio Director and Music Producer

  • You must to post comments
Best Answer
0
0

There is an issue with identifying events using plugin spatializers as 3D. And this doesn’t play will with the logic in the Unity emitter script to only pass positions to events if they’re 3D.

We’re looking to get the fix in for 1.08.01.

As a work around you can change StudioEventEmitter.cs line 114 from

eventDescription.is3D(out is3D);

to

is3D = true;
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.