Answered
0
0

I’m working on an adaptive music system with FMOD Studio and UE4.

The whole soundtrack is currently set up in one single event.

As it is supposed to carry on smoothly accross level transitions, the “PlayEvent2D” is called right at the start of the game; a good amount of variables takes care of the rest (such as transitions, timeline logic and vertical layering).

To achieve that, a SoundMaster blueprint checks relevant variables and gives parameters to the soundtrack event via “Find Event Instances” (of the soundtrack event) -> “get” with #0 (getting the first instance out of the array) and using that as event instance for the parameter change.

All music stems consist of timelocked modules, around 2 minutes in legth each.

Now every time an FMOD parameter is changed (mostly volumes between 1 and 0), ingame tracks start to noticeably step out of sync (namely the ones being affected by said change). After repeating the process 2-3 times, certain tracks are close to half a bar behind, after a few more times several bars until the loop starts over and everything is back together. Thus, frequent changes in parameters break the music entirely, whereas no action leaves the music perfectly in sync (the parameters are still set to the same value evey .1 seconds).

I’ve read about various potential fixes such as changing from streaming audio to sample audio and preloading it in RAM (see this topic: http://www.fmod.org/questions/question/layers-going-out-of-sync/), but that didn’t seem to change anything on my end.

Is there another solution (perhaps related to the way the event instance communication is set up) or are multi-channel wavs the only way out of this? I have around 13 stems playing back simultaneously; some shorter and thus looped; only up to 3 audible at the same time; switching to multichannel wav would be a very painful, time-consuming last resort…

  • You must to post comments
Best Answer
0
0

Please try setting the priority of the event to “highest”, it should solve the desyncing issue.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.