I’m using FMOD to create a smooth transition between the Menu (which has 3 layers that fade in as you progress) and Gameplay music.

I have it set up that the 3 Menu layers are Event Sounds and continue over all of the branching gameplay tracks (which are contained on 1 audio track) I’m using the Transition Regions Timelines to fade back and forth between the menu and gameplay. Here’s a screenshot.

In FMOD it sounds great, no problems at all. But when in Unity (happening both when implemented and in the inspector preview) it plays through the transition timeline I have set up, but instead of just continuing the Event Sound like it should, it restarts the Event Sound. Here’s a video showing the transitions.

I’m at a loss on how to get it working right. Any help would be super appreciated!

  • You must to post comments
Great Answer

If there is a difference between what you hear in Studio and what you hear in the game, the first thing I would check is that the tool and the game are using the same version of FMOD.

Normally it’s okay if the versions are not an exact match (any 1.06.xx runtime should be able to load banks produced by any 1.06.yy tool), but maybe you have run it to a subtle difference in behavior between two different versions. So best to eliminate that possibility by ensuring that both the game and the tool are on the same FMOD version.

If you still have a problem, the next step would be to contact, so we can investigate this in more depth.

  • Clark Aboud
    You better believe I have my face in my palm right now... I've been meaning to update, but thanks to a ProTools debacle a while back, I always wait to update software until after I'm finished a job. It's all working perfectly now, thanks so much for the extremely fast help!
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.