Answered
0
0

Hello everyone!

I work on an Android UE4 game projet since 3 months,
I use Fmod for it since 1 month and everything was wonderfull…

…until I decided to update from Fmod 1.07.05 to the new 1.08.

When I play my prototype in Unreal Editor, everything is ok,
but when I launch it on my device (Galaxy S6) sounds have many bitcrushes, its horrible.
I tried many setup, Vorbis quality 100% compressed, etc. but the problem is still here.

PC : https://drive.google.com/file/d/0Bx0GqVBcSxt5MUJFRFRXSGdKU1U/view?usp=sharing
Android : https://drive.google.com/file/d/0Bx0GqVBcSxt5YVc3Smp6a0lWVjQ/view?usp=sharing
(You can hear the “iiiiiii” at the end of the death sound)

Is it a bug with Fmod 1.08 or is it me ?

I’m tring to fix it since 2 days : unistall / reinstall / rebuild the project / rebuild the editor / etc. etc. etc. I totally despair.

  • You must to post comments
Best Answer
0
0

Hi Brett Paterson,

Thank you for this very fast response !

I play the sound like this : https://drive.google.com/file/d/0Bx0GqVBcSxt5bEZRUWhWbllxVkk/view?usp=sharing

Here is the Fmod project : https://drive.google.com/file/d/0Bx0GqVBcSxt5dFFual9UOEZlRVU/view?usp=sharing

Sorry but I dont know how to do an “API capture using the FMOD Studio profiler”. Can you explain me, or give me the link to an explanation to do it?

Best regards,

  • Mathieu Labelle

    I just tried with a Fmod 1.08 blank project.
    – I put only this sound : https://drive.google.com/file/d/0Bx0GqVBcSxt5dnZMeEd3cmhvb1E/view?usp=sharing
    – And build the bank for Mobile plateform in my Unreal game project (4.10.2, not 4.10.4, my mistake)

    The bitcrush is still there.

  • Geoff Carlton

    That waveform looks very odd and has a deliberately strange effect on it. When you play that sound in Studio does it sound how you expect it to? Can you describe how it sounds different on mobile to when its played on PC?

    The best thing to do is to connect to the game in FMOD Studio and record a profiling session, which will include the audio. You should be able to connect to the ip address of your mobile device when launching your mobile title from UE4. From there, bring up the profile window in Studio, create a new session and record it.

    You should be able to play it back afterward and hear the same sound the game made on the device. If you have isolated the issue you can then contact support and send in the profile capture so we can examine it.

  • Mathieu Labelle

    It’s not due to the sound, because in Studio everything is OK, in UE4 Editor it’s OK, and on Android with Fmod 1.07.05 it was perfect.

    The bitcrushing is not with this sound only, it does with all the sounds, but it is much more pronounced with certain sounds, like the one I sent.

    I’ll try to record the sound like you explain (if I understand every steps, because my English is bad… ^^).

    Can you assure me that this is supposed to work well on Android with Fmod 1.08 or it’s not sure at all? :’)

  • Geoff Carlton

    Yes, there aren’t any known issues with 1.08 and Android that would cause that, so it should work. If you get a capture we can look into what is going on.

  • You must to post comments
0
0

Hi Mathieu
If you go to previous versions on the download page , ie https://www.fmod.org/browse-studio-api/ you could get 1.07.08 as an update to 1.07.05, instead of jumping to 1.08.

That is hard to diagnose but can you tell me how you play the sound? Is it an FMOD Studio event? Or are you playing a sound using the low level API.
Are there any effects on the event?

You could try an API capture using the FMOD Studio profiler, and send us the files it creates, and if you could send the studio project as well that would be good, we could then run it on an android device here.
regards,

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.