1
0

I am using UE 4.14 source version, but I am unable to get FMOD to compile as I have done in the past.

The image below shows the errors that my compiler identifies:
image

Errors:

Error C2248 ‘FViewMatrices::ViewMatrix’: cannot access private member declared in class ‘FViewMatrices’ UE4 C:\Users\Documents\UnrealEngine-4.14.0-release\Engine\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODStudioEditorModule.cpp 864

Error Failed to produce item: C:\Users\Documents\UnrealEngine-4.14.0-release\Engine\Plugins\FMODStudio\Binaries\Win64\UE4Editor-FMODStudioEditor.dll UE4 C:\Users\Karan\Documents\UnrealEngine-4.14.0-release\Engine\Intermediate\ProjectFiles\ERROR 1

  • You must to post comments
0
0

I had the same problem the first time I compiled the 4.14 source. Did you make sure to copy over the Binaries folder from 4.13 UE4 download and paste it into the FMOD Plugin folder? Once I did this, the compile worked. http://www.fmod.org/download/

  • Karan Parikh

    Thanks for the suggestion, Stuart. I just tried copying over the Binaries folder from my 4.13 version. However, I am still running into the same errors when I try and compile my engine in Visual Studio

  • Stuart B Newsom

    Which version of Visual Studio are you running? Did you get your Fmod source from here: https://github.com/fmod/ue4integration?

    The main difference between my source and yours is the fact that my plugin is built from my project and not my engine. Might be a minor thing that made all the difference. Also, when you say you’re copying over the binaries from your 4.13 version, do you mean you didn’t download a fresh copy from the link above? That could also make a difference.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.