Answered
0
0

I finally managed to build my project with UE 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 plugins.

It runs on the device with sounds (spatialized sound evens are a way too loud, but I’ll have to check if physical volume was set on the device too loud)

However, spatialized sounds don’t play in PIE / Editor (sounds that use Oculus spatializer plugin).

Here is what I am getting in the log:

http://pastebin.com/cPmEhNpA

and here are my settings for FMOD:

https://www.youtube.com/watch?v=ZsHAZiQmOBA

Please do not suggest to rename anything because A. everything works fine in 4.14.3 with exact the same settings and B. renaming doesn’t solve the issue.

Thanks beforehand

P.S. Tried Oculus Audio SDK 1.1.2 plugins and I get no errors as posted above and spatialized sound events play in PIE / Editor.

  • You must to post comments
Best Answer
1
1

The problem is it is looking for a plugin named libOculusSpatializerFMOD.
The plugin adds any prefixes it needs for each platform. It just needs to be OculusSpatializerFMOD.

  • Alex Zubov

    Alright, I will test it later today. Thanks.

  • Cameron Baron

    Also make sure you have followed the steps for deploying on Android with plugins: http://www.fmod.org/documentation/#content/generated/engine_ue4/deployment.html

  • Alex Zubov

    Removing libOculus* entry from Project Settings removed the error, however, unless I disable XAudio2 audio device in the WindowsEngine.ini, I get no spatialized sound when using Oculus Audio SDK 1.1.3 plugins. Works fine with 1.1.2 without disabling audio device.

    Going to deploy and see how it works on the device. Will report in a bit.

    Meanwhile, these are the warning I get in the log pertaining to FMOD:

    https://pastebin.com/L38KhEdr

  • Alex Zubov

    Tested – works on the device too.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.