0
0

Is anyone using UE4 4.13 + FMOD for Google Daydream? It works in the editor with mobile preview, but when it’s deployed to the device, I hear no FMOD sounds. It appears that all the library files, fmod.jar, libfmod.so, libfmodstudio.so, libgvraudio.so are being correctly packaged up. And it looks like GameActivity.java is loading the fmod and gvraudio libraries. Here’s a snippet of GameActivity.java:
try
{
System.loadLibrary(“fmod”);
}
catch (java.lang.UnsatisfiedLinkError e)
{
Log.debug(“libfmod not loaded and required!”);
}
try
{
System.loadLibrary(“fmodstudio”);
}
catch (java.lang.UnsatisfiedLinkError e)
{
Log.debug(“libfmodstudio not loaded and required!”);
}
try
{
System.loadLibrary(“gvraudio”);
}
catch (java.lang.UnsatisfiedLinkError e)
{
Log.debug(“gvraudio not loaded and required!”);
}

I tried looking at the adb logcat output, but there’s only one entry for fmod,
I fmod : FMOD::supportsLowLatency : Low latency = true, Pro Audio = true, Acceptable Block Size = true (192)
Does anyone have any suggestions about how to proceed? Thanks in advance for any help.

  • Eugene Chung

    I might have been running adb logcat with some bad parameters. Here’s the FMOD output from a clean run of adb logcat (looks like Gvr Audio Listener Plugin is missing, so that’s probably Google’s problem):
    ——— beginning of main

    ——— beginning of system

    10-27 10:37:28.287 13397 13417 D UE4 : [2016.10.27-17.37.28:287][ 0]LogPluginManager: Loaded Plugin FMODStudio, From ../../../ExampleUnrealProject/Plugins/FMODStudio/FMODStudio.uplugin

    10-27 10:37:28.334 13397 13417 I fmod : FMOD::supportsLowLatency : Low latency = true, Pro Audio = true, Acceptable Block Size = true (192)

    10-27 10:37:28.539 13397 13417 D UE4 : [2016.10.27-17.37.28:539][ 0]LogFMODOculus: StartupModule
    10-27 10:37:28.539 13397 13417 D UE4 : [2016.10.27-17.37.28:539][ 0]LogFMOD: FFMODStudioModule startup
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Lib path = ‘../../../ExampleUnrealProject/Plugins/FMODStudio/Binaries’
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Loading strings bank: ../../../ExampleUnrealProject/Content/FMOD/Mobile/Master Bank.strings.bank
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Skipping asset: bus:/
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Constructing asset: /Game/FMOD/Events/New_Event
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Skipping asset: bank:/Master Bank.strings
    10-27 10:37:28.540 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Constructing asset: /Game/FMOD/Banks/Master_Bank
    10-27 10:37:28.541 13397 13417 D UE4 : [2016.10.27-17.37.28:540][ 0]LogFMOD: Creating runtime Studio System
    10-27 10:37:28.541 13397 13417 D UE4 : [2016.10.27-17.37.28:541][ 0]LogFMOD: Default sample rate = 24000
    10-27 10:37:28.541 13397 13417 D UE4 : [2016.10.27-17.37.28:541][ 0]LogFMOD: System sample rate = 48000
    10-27 10:37:28.541 13397 13417 D UE4 : [2016.10.27-17.37.28:541][ 0]LogFMOD:Warning: ../../src/fmod_systemi.cpp(2706) – Output requires a sample rate of 48000Hz, resampling will occur.
    10-27 10:37:28.541 13397 13417 D UE4 :
    10-27 10:37:28.541 13397 13417 D UE4 : [2016.10.27-17.37.28:541][ 0]LogFMOD: Loading plugin ‘gvraudio’
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:541][ 0]LogFMOD: Trying to load plugin file at location: gvraudio.so
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:542][ 0]LogFMOD:Error: ../android/src/fmod_os_misc.cpp(998) – dlopen failed: library “gvraudio.so” not found
    10-27 10:37:28.542 13397 13417 D UE4 :
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:542][ 0]LogFMOD:Error: ../android/src/fmod_os_misc.cpp(998) – dlopen failed: library “gvraudio.so” not found
    10-27 10:37:28.542 13397 13417 D UE4 :
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:542][ 0]LogFMOD: Trying to load plugin file at location: gvraudio32.so
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:542][ 0]LogFMOD:Error: ../android/src/fmod_os_misc.cpp(998) – dlopen failed: library “gvraudio32.so” not found
    10-27 10:37:28.542 13397 13417 D UE4 :
    10-27 10:37:28.542 13397 13417 D UE4 : [2016.10.27-17.37.28:542][ 0]LogFMOD:Error: ../android/src/fmod_os_misc.cpp(998) – dlopen failed: library “gvraudio32.so” not found
    10-27 10:37:28.542 13397 13417 D UE4 :
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD: Trying to load plugin file at location: libgvraudio.so
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD: Loaded plugin gvraudio
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD: Triggering Initialized on other modules
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMODOculus: FMOD_OSP_SUPPORTED is not enabled
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD: Loading Banks
    10-27 10:37:28.543 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD:Warning: ../../src/fmod_effect.cpp(189) – Missing DSP plugin ‘Gvr Audio Listener Plugin’
    10-27 10:37:28.543 13397 13417 D UE4 :
    10-27 10:37:28.544 13397 13417 D UE4 : [2016.10.27-17.37.28:543][ 0]LogFMOD:Error: ../../src/fmod_bankmodel.cpp(247) – DSP plugin returned an error, bank will not load properly.
    10-27 10:37:28.544 13397 13417 D UE4 :
    10-27 10:37:28.544 13397 13417 D UE4 : [2016.10.27-17.37.28:544][ 0]LogFMOD:Warning: Failed to bank: ../../../ExampleUnrealProject/Content/FMOD/Mobile/Master Bank.bank (A requested output, dsp unit type or codec was not available.)

    10-27 10:37:29.261 13397 13417 D UE4 : [2016.10.27-17.37.29:261][ 0]LogFMOD:Warning: ../../src/fmod_objectlookup.h(115) – Lookup failed for EventModel: {53e945c7-ab23-4d8d-8914-dca39ed82136}

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.