Answered
0
0

Hi,

I’m working on a project in UE4 but every time I package the game, no sound is being played. I’ve check copying the .dlls in the folders, the master banks as some of the forums suggested but still, no sound.

Don’t know if there’s something I’m missing either in UE4 or FMOD so if someone could point it out or had the same issue but found a solution, please let me know, I really don’t know what is going on.

Thanks.

  • You must to post comments
Best Answer
1
1

Firstly, try running “validate” from the UE4 help menu. It will try to find common problems and fix them up for you.

When packaging up a development build, the game will write out a log file when you run the game. Have a look there for any warnings/errors from FMOD. Messages to look for are:

  • Failing to load FMOD .dll files (this shouldn’t happen since the integration does it for you)
  • Failing to load bank files (missing FMOD directory to package in the packaging settings, or not having the bank platform e.g. mobile)
  • Failing to load events due to missing plugins (missing plugin.txt to get the plugin files into the deployed directory)

A last issue to be aware of is if you have references to FMOD in your blueprints, but you also load blueprints up statically before initialization has finished. See the “Loading blueprints before plugin load” section at the end of this page:

http://www.fmod.org/documentation/#content/generated/engine_ue4/deployment.html

If you see in the log that you FMOD .dlls have loaded, and the banks have loaded, but you still can’t hear sound, then you can connect FMOD Studio profiler and record a session. That way you can verify that its creating FMOD events as you expect.

  • Andrés

    I can’t thank you enough. The solution was to use this IFMODStudioModule::Get(); above the ConstructorHelper.

    Thank you very much!

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.