Answered Closed
0
0

I have created a VR project and I’m using FMOD Studio along with the Oculus Spatializer Plugin. In the editor the FMOD sounds play fine, however when I packaged the project there are no FMOD sounds at all.

In the log I get errors like this:

LogFMOD:Error: e:\jk\workspace\1. Build_UE4_1.9_Libs\lowlevel_api\platforms\win\src\fmod_os_misc.cpp(794) – LoadLibrary failed to open ‘../../../Engine/Plugins/FMODStudio/Binaries/Win64/OculusSpatializerFMOD.dll’, GetLastError = 126

LogFMOD:Error: Failed to load plugin ‘OculusSpatializerFMOD’, sounds may not play

LogFMOD:Warning: e:\jk\workspace\1. Build_UE4_1.9_Libs\studio_api\src\fmod_effect.cpp(189) – Missing DSP plugin ‘Oculus Spatializer’

I have set it all up as in the documentation so added the plugin in the advanced settings and added ‘FMOD” to Additional Non-Asset Directories to Package’

But I’m a bit stuck now.

Using 4.15.3, FMOD 1.09.04 and packaging to Windows x64

  • M
    • M
    • 2 months ago

    Update: If I remove the Oculus Spatilizer plugin from all the events and from the UE4 project, the FMOD sounds build correctly.

  • You must to post comments
Best Answer
0
0

Have you added the OculusSpatializerFMOD.dll into the binaries folder?
(‘../../../Engine/Plugins/FMODStudio/Binaries/Win64/OculusSpatializerFMOD.dll’)

  • M
    • M
    • 2 months ago

    Ah I have now and it works just fine!

    Thanks :)

  • You must to post comments
Showing 1 result