0
0

Right now I have the FMOD event being played as a component attached to a pawn(vehicle). Now this plays a stereo signal, but even if I change the settings in FMOD, it has no bearing on UE4 in game world.
I can get attenuation to work with UE4 assets or bringing stuff in, just not with FMOD audio components.

Is there something I’m missing here?
Is the only way to set up the component with a sound cue?

  • You must to post comments
0
0

Best way to track this down is run PIE and connect FMOD Studio, then record a profiling session.

It will record the event instances and their position. When you replay the profile session, you should see the event instances appear on the 3d radar panel as the emitter and listener move around.

That can help verify that FMOD is getting the position properly. Another thing to check is that you are using the built in panner, or if using a third party panner that it supports attenutation. Early versions of the Oculus panner would pan the signal around but left the falloff attenuation up to event – by setting a volume attenuation curve on the automatic Distance parameter.

If you record the capture and still can’t work out why it isn’t sounding right, you can contact support@fmod.com and send in a zip of the capture + banks.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.