Answered
0
0

Hi all,
Firstly thankyou for the great UE4 plug-in and tutorials. I’ve got FMOD Studio assets working like a dream within UE4 plus i’m able to connect to the engine for real-time mixing no problem.

The problem I have is when I come to building the project in UE4 I am faced with the following error message:

http://i.imgur.com/xvKcTmc.jpg

The dialogue appears on trying to open the game executable.
The plug-in is installed correctly as I am able to use FMOD Studio banks and events within UE4 so I was wondering if you could offer any guidance as to why this error message is appearing?

Many thanks,
Mark

(P.S. The plug-in appears to only be working with UE version 4.4.3 and not 4.5)

  • You must to post comments
Best Answer
1
0

This is an issue with plugins and binary only projects. If you download the UE4 binary and create a blueprint-only project, then code plugins won’t be linked into your final executable. It just doesn’t work. We recommend the same as the other code plugins, which is to create a code project even if you don’t want to add any code classes to your project.

If you do create a code project (even an empty one), then it will link correctly. You will then have to do two steps to get deployment working:

  • Ensure that the FMOD directory is included in the packaging settings.
  • Manually copy over the FMODStudio third party DLLs to the StagedBuilds directory once deployment has finished.

See the Deployment section in the chm for more details of the above steps.

We have raised support issues with Epic and I’m hopeful these will be resolved in time (although unfortunately they aren’t fixed in 4.5 by the look of it).

  • Corentin Derbré
    Can you elaborate on that two steps? I am on mac with binary UE 4.7, a code project, but the builds play without FMOD? It works fine in-editor.
  • Corentin Derbré
    SOLVED: i just needed to add the FMOD folder (in content) to "Project Settings> Packaging > Additionnal Non-Asset Directories To Copy"
  • You must to post comments
0
0

Hi,
From your description it sounds like you are using the binary UE4 distribution (which means you downloaded UE4.exe etc from the launcher, rather than using github). Is this correct?

What platform are you using, windows or Mac? Is your project blueprint only or is it a code project?

There are issues getting the dynamic FMOD libraries deployed into the launch directory which are documented in the help, but that pop up is not what I would expect.

  • You must to post comments
0
0

Hi, thanks for the response.
You’re absolutely right, it is the binary UE4 distribution. I’m using Windows 7 (64-bit) and the project is blueprint only.
Thanks,
Mark

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.