Answered
0
0

Hi Learned folks of Fmod and unreal!

I have Studio working like a dream within the UE4 editor, even in Standalone – but when I create a package, none of the FMod audio plays.

I suppose this is to do with missing data or something when it creates the package?

Anyone able to offer any wisdom?

UE4.7.6
Fmod Studio 1.06.03

Trying this with both a 2d and 3d sound.

thanks in advance, awesome sound peeps!

  • You must to post comments
Best Answer
0
0

Hi,
The most common issues are described here:

http://52.88.2.202/documentation/#content/generated/engine_ue4/deployment.html

You will need to include the FMOD in the directories to package. For windows, you will need to make sure the .dll files are manually copied into the thirdparty directory.

  • Al
    • Al
    • 1 year ago
    Thanks Geoff Assuming I'm not being an idiot here, I've manually copied the FMODStudio directory containing the .dll files from my Unreal installation folder to the package engine/binaries/thirdparty folder - but still no dice... -- the link above suggests they're copied to Engine/Binaries/ThirdParty/FMOD/Win32 Engine/Binaries/ThirdParty/FMOD/Win64 but with studio should be - Engine/Binaries/ThirdParty/FMODStudio/Win32 Engine/Binaries/ThirdParty/FMODStudio/Win64 correct? -- For clarity - I've also added the FMOD directory to the "additional non-asset directories to package" section. I've also added the requisite ovrfmod as a plugin File in the Advanced section of the FMOD Studio Plugin in editor preferences. Again, the error I'm getting on booting the executable is: "Plugin 'FMODStudio' failed to load because module 'FMODStudioOculus' could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project" At a bit of a loss...!
  • Geoff Carlton
    All .dll files should be copied into the same directory, so for 64bit they should go into ThirdParty/FMOD/Win64. That includes the studio dll as well.
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.