Answered
0
0

Hi,

I was having issues with the latest Unity integration after having updated to the latest versions of both Unity (5.5.2) and FMOD (1.09.02), then I followed the steps in the troubleshooting section of the integration manual, deleting the fmodl.dll and fmodstudiol.dll from Assets\Plugins\x86_64. This helped a little, as now I can access events through the event browser, and play them to ensure they’re all there, whereas before I was unable to do even that. However, when I go to play the project in editor I get this error, one for each emitter in the project:

SystemNotInitializedException: FMOD Studio initialization failed : Loading plugin ” from ‘E:/Users/Nick/Desktop/Everything/Game projects/Selene/Blender_HightMap_Test/Assets/Plugins/X86_64/.dll’ : ERR_FILE_NOTFOUND : File not found.
FMODUnity.RuntimeManager.CheckInitResult (RESULT result, System.String cause) (at Assets/Plugins/FMOD/RuntimeManager.cs:148)
FMODUnity.RuntimeManager.Initialiase (Boolean forceNoNetwork) (at Assets/Plugins/FMOD/RuntimeManager.cs:264)
FMODUnity.RuntimeManager.get_Instance () (at Assets/Plugins/FMOD/RuntimeManager.cs:79)

additionally I get one of these as well:

NullReferenceException: Object reference not set to an instance of an object
FMODUnity.RuntimeManager.OnDisable () (at Assets/Plugins/FMOD/RuntimeManager.cs:536)

I’m using 64 bit windows, FMOD integration 1.09.01 (as its the latest available).

Any thoughts on how to fix this would be really appreciated, work has ground to halt as
a result of this!

Regards,

Nick

  • You must to post comments
Best Answer
1
1

It appears you may have accidentally added an empty plugin field to the Unity FMOD Settings. This shouldn’t be an issue but in the meantime make sure any unused fields are deleted to avoid this error.

  • Nicholas

    Oh my sweet lord… Thank you so much man. It seems that before I read the troubleshooting guide I tried fixing the original problem by adding a plugin, failed, left the field blank then went on my merry way, only to sow the seeds of my subsequent undoing… Thanks again dude, nice catch.

    N.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.