Answered
0
0

The developers of the game I’m working just upgraded to 4.14, they use Windows, installed the integration plugin for 4.14 and everything is working just fine. In the other hand, on MacOs 10.11.6, I cant open the project, or even a blank project on 4.14.

If I delete the Fmod plugin folder from the Plugins folders, everything work, but when I put the Fmod folder again, I keep receiving the message:

“Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ does not appear to be compatible with the current version of the engine. The plugin may need to be recompiled.”

I double checked the version, downloaded and redownloaded everything, even the Unreal Engine, and nothing seem to work.

Am I doing something wrong?

  • Cameron Baron

    What version of our plugin are you trying to use?

  • Teo Oliver

    I was trying the version Version fmodstudio10901ue4.14mac, after testing everything with no sucess, I just installed the fmodstudio10815ue4.14mac to see what would happen. It didn’t loaded the banks as I was expecting, but at least it let me open the project to see one animation the developers wanted me to start working on the sound.

  • Cameron Baron

    It looks like on Mac it may not have been built using the very latest version of UE 4.14, that is all the error means. It will still work if you tell it to rebuild, the engine doesn’t seem to like mismatched engine versions, even minor versions.

  • Howu

    I think you should recompile the plugin’s binaries.
    Try this.
    1) Delete ‘Intermediate’ folder, and All the “UE4*” files of “Binaries” folder’s subfolders.
    2) Open UE Project, and answer yes to the question box “Recompile blablabla ~~”.

    If your project is a blueprint project, you should make another “C++ project” and recompile through this process, and just copy fmod plugin folder to your own blueprint project.

    I think it’ll be ok.

  • You must to post comments
Best Answer
0
0

You may need to recompile the plugin to work with the version of UE4 that you are using.
Refer to the bottom of: Getting Started. To do this the plugin will need to be in the project directory and not the engine’s.

If the engine version used to build the plugin doesn’t exactly match the version you are trying to use (eg. 4.14.0 & 4.15.0).

  • You must to post comments
0
0

I’m still struggling with this, I tried everything but nothing really works…don’t know what to do?

Maybe do a clean instal of MacOs on my machine? Could this help?

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.