Answered
0
0

to test the Google VR plugin (GVR) that now ships with v1.09, I did the following:

in FMOD Studio 1.09:
– created an event, containing a single looping “ping”
– on the Master track, deleted the default 3D Panner, and replaced it with a GVR Source
– in the mixer, deleted the Reverb return, and added a GVR Listener to the Pre effects on the Master bus
– played the event (seems to be working as expected) and built Desktop

in Unity 5.4 (and Unity 5.6 beta):
– imported fmodstudio10901_v2.unitypackage
– added a StudioListener to the Main Camera
– In FMODStudioSettings/Project, set StudioProjectPath to the .fspro file
– added a sphere object to the scene and attached a StudioEventEmitter to it
– in the StudioEventEmitter, set the Event to “event:/ping” (from search) and set PlayEvent to ObjectStart
– play the Unity scene

Expected Result:
Looping “ping” sound that I can move around to test the GVR plugin

Actual Result:
Continuous error messages:

BusNotFoundException: FMOD Studio bus not found ‘bus:/’
FMODUnity.RuntimeManager.GetBus (System.String path) (at Assets/Plugins/FMOD/RuntimeManager.cs:863)
FMODUnity.RuntimeManager.MuteAllEvents (Boolean muted) (at Assets/Plugins/FMOD/RuntimeManager.cs:887)
FMODUnity.RuntimeManager.Update () (at Assets/Plugins/FMOD/RuntimeManager.cs:391)

Note: if I remove the GVR Listener from the Master bus, the event plays as expected (looping, but not spatialized).

What am I doing wrong?

  • You must to post comments
Best Answer
0
0

There should also be an error line with “ERR_PLUGIN_MISSING”.
Make sure you add “gvraudio” to the list of plugins in FMOD->Settings.

http://imgur.com/GVMK1pP

We don’t include it automatically as not every project will need it.
Google have all the steps documented here.

  • You must to post comments
0
0

yup, that did it! (and i’d looked at that developers page, but obviously missed that line, d’oh!) thanks!!

  • You must to post comments
0
0

I just want to apply the Google VR in the fmod VS2013 project, and got “ERR_PLUGIN_MISSING”. How to fix this?
I have already include the “Google VR/inc” and “Google VR/lib” in the VS project.

  • Cameron Baron

    If you aren’t using Unity or having the same issue as the initial question, it would be best to start a new thread of your own. Please try to include as much information as possible to make it easier for us to help.

  • Dongming

    I’ve already fixed this, thank you very much. I’ll add my solution below.

  • You must to post comments
0
0

I don’t use unity, I just use the Google VR plugin in my C++ code in VS2015, because I need to use fmod in my own software.

I refer to the examples as well as FMOD Studio Programmers API for Windows, and then add the following code:

FMOD::System* lowLevelSystem = NULL;
unsigned int i = 0; //which I don't really know what it is used for
system->getLowLevelSystem(&lowLevelSystem);
std::cout<<lowLevelSystem->loadPlugin("gvraudio.dll", &i, 0)<<std::endl;

and then put the ‘gvraudio.dll’ file together with the main executable file (.exe), which works fine for my demand.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.