0
0

Hello,

I’m getting this warning in Unity while running on the Wii U platform.

FMOD Studio: copy banks for platform WiiU : Unsupported platform
UnityEngine.Debug:LogWarning(Object)
FMODUnity.EventManager:CopyToStreamingAssets() (at Assets/Plugins/Editor/FMOD/EventManager.cs:414)
FMODUnity.EventManager:Update() (at Assets/Plugins/Editor/FMOD/EventManager.cs:530)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()

It doesn’t seem to be preventing the game from playing audio in Debug mode in the Unity IDE or on the Debug mode of the Wii U. But when I try running in production/master mode on the Wii U, the game runs out of memory quickly.

I’m wondering if this warning could have something to do with that. Or even if I can just rule this out as a cause for the memory issues. I’d like to know better what this warning means, and if I can somehow fix it, or if I can safely ignore it.

Thanks,

MD

  • You must to post comments
0
0

What version’s are you using? ( Unity and FMOD Integration )

Also just in case, for consoles you will need an additional package from us that contains the specific libs for the platform.

  • You must to post comments
0
0

Hi Cameron,

We’re using FMOD Studio version 1.08.03.
Integration Version: 1.08.13.

I’ve installed the Wii U console package from the FMOD website (with special permissions), but I’m unsure if I need to do anything else. The FMOD sound does work when I run it on the Wii U console, so I think that’s set up properly.

When I switch Unity into Wii U platform mode, or update the FMOD project/bank directories or settings, the “FMOD Studio: copy banks for platform WiiU : Unsupported platform” error gets printed to the Unity Console.

Again, the sound does work on the Wii U, but we’re having memory issues, so my concern is maybe the proper banks are being build to the Wii U dev kit, and thus we’re running out of memory.

Thanks again for the help,

MD

  • Cameron Baron

    First thing I would suggest is using the latest integration available. I believe it should solve any issues you are having.

  • You must to post comments
0
0

I can confirm that upgrading the integration to 1.09 did remove this warning.

Thanks for helping!

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.